Firefox not preloading background images

Mozilla Firefox is a great internet browser, and I just love tabbed browsing. Each day I look in Bloglines to see which sites have been updated, and I open up all interesting reading matter in new tabs — I CRTL-click more than I click. After that I go one by one through my tabs, reading each page and opening interesting links in new tabs. I continue doing so until I have closed all my tabs, or until I run out of time, in which case I simply bookmark all open tabs. The good thing about loading pages on tabs it that I can load many pages before I read them; each time I close a tab, I find a new page waiting for me.
But there is one thing that annoys me. As you might know, I am very interested in web design, and many sites I read are about standards web design. Therefore, more and more sites I visit are standards compliant: clean HTML and designed with CSS. In my opinion Firefox does not handle these sites correctly, since it only starts loading background images the moment I focus on a tab. Thus many times I close a tab, I am confronted with an almost white page with some text on it, which then is converted little by little in a beautiful design. I do not understand why Firefox waits until I focus on the tab and does not pre-load the background images while I am reading other sites.
Or is there some hidden configuration option I don’t know about?

Advertisements
Firefox not preloading background images

6 thoughts on “Firefox not preloading background images

  1. I had this exact problem with Firefox .8. Sometimes it NEVER loaded the BG images of a site, especially mine, and I found it highly irritating. Since then I have gone back to Firebird .7 which renders pages perfectly but now have other quirks. it’s a catch-22. If you find a fix, please let us know. I never did and I worked with it for a few weeks. I just got tired of it and went back to FB .7.

    Like

  2. So my fear is correct, it has to do something with my settings. I had a look in about:config and put almost everything back to their default values, except for some obviously unrelated things as browser.startup.homepage and some settings which I did not dare to change (intl.charsetmenu.browser.cache, security.OCSP.signingCA, signon.SignonFileName). I opened up my bookmarks page and CTRL-clicked some sites as Dive into mark, CSS Zen Garden and Zeldman. I waited until the favicon appeared on all tabs, and went to see the sites. They did not have their headers loaded; I had to wait some seconds to see them in all their glory ;-(
    I desperately need some help on this one!

    Like

  3. I don’t have this problem, nor can I remember this from previous versions. Tabbed browsing is just great! When I click on a tab, the content is just there, including background images.

    Like

Comments are closed.